Issues receiving inbound calls through our helpdesk
Incident Report for Whispir - Status
Resolved
This incident has been resolved.
Posted Dec 12, 2023 - 09:47 AEDT
Identified
We are currently having issues receiving inbound calls via our helpdesk due to an issue with our supplier. We will provide updates on this this issue as we get them. In the meantime for any support related inquiries you may send us an email at support@whispir.com
Posted Dec 12, 2023 - 09:18 AEDT